using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\'|"")My-Text(\'|""):.*?((input-src|output-src|x-src)).*?(?!(perfect-inline|perfect-eval|\*))";
string input = @"{''Remote-Control': 'no-control, must', 'My-Text': ""input-src 'something' 'perfect-out' 'perfect-in' *.exampl.com"", 'Some': '1; 'Encoding': 'gzip'}
{''Remote-Control': 'no-control, must', 'My-Text': ""input-src *"", 'Some': '1; 'Encoding': 'gzip'}
{''Remote-Control': 'no-control, must', 'My-Text': ""output-src *.exampl.com"", 'Some': '1; 'Encoding': 'gzip'}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}