# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(?:abc|sst)\w*//gm;t' <<< "error in node occurred in sstlgh8j at 10pm afterabchjk9j after 12pm
error in node occurredsstlgh8j at 10pm after abchjk9j after 12pm"