use strict;
my $str = 'error in node occurred in sstlgh8j at 10pm afterabchjk9j after 12pm
error in node occurredsstlgh8j at 10pm after abchjk9j after 12pm';
my $regex = qr/\s*(?:abc|sst)\w*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";