use strict;
my $str = 'This is [test] version';
my $regex = qr/\[[^]]+\]/mp;
my $subst = '1.0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";