using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b[A-ZА-Я](?:[,;:-—’()\w]+? ){3,}\w{2,}[.!?])";
string input = @"Medically reviewed by Andrea Hodgson — Written by Susan York Morris — Updated on September 2, 2018
Introduction
Тест тест тест тест тест тест тест тест тест.
Kdenfjr - fkefkwfwf kljmlk lklkjol klmlmkl klkoik kjio.
Erectile dysfunction (ED) is a problem with getting and maintaining an erection that’s firm enough to have sexual intercourse. All men have trouble getting an erection from time to time, and the likelihood of this problem increases with age. If it happens to you often, though, you may have ED.
Viagra is a prescription drug that can help men with erectile dysfunction. For many people, romance means candlelight, soft music, and a glass of wine. The little blue pill, Viagra, can be part of this picture, but only if you drink small or moderate amounts of alcohol.
• Market Data
Currency pairs Find out more about the major currency pairs and what impacts price movements.
Commodities Our guide explores the most traded commodities worldwide and how to start trading them.
Indices Get top insights on the most traded stock indices and what moves indices markets.
Cryptocurrencies Find out more about top cryptocurrencies to trade and how to get started.
• Calendars
Long Short
Note: Low and High figures are for the trading day. Data provided by
Long Short";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}