$re = '/<([A-Za-z_{}()/]+(\s|=)*)+>(.*<[A-Za-z/>]+)*/i';
$str = '<img src=x onerror=do_evil()/>
<script>$(blabla).click();</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);