import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@if(?:\\s+|)\\(([\\s\\S]*?)\\)([\\s\\S]*?)+@endif";
final String string = "<div class=\"wrapper\">\n"
+ " <p>Parágrafo fora dos ifs.</p>\n\n"
+ " @if (true)\n"
+ " <div>Oi?</div>\n"
+ " @if (false)\n"
+ " <span>Não devo ser renderizado</span>\n"
+ " @endif\n"
+ " @endif\n\n"
+ " <p>Estou entre os if's</p>\n\n"
+ " @if (true)\n"
+ " <div>estou em outro if</div>\n"
+ " @endif\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}