# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@if(?:\s+|)\(([\s\S]*?)\)([\s\S]*?)+@endif"
test_str = ("<div class=\"wrapper\">\n"
" <p>Parágrafo fora dos ifs.</p>\n\n"
" @if (true)\n"
" <div>Oi?</div>\n"
" @if (false)\n"
" <span>Não devo ser renderizado</span>\n"
" @endif\n"
" @endif\n\n"
" <p>Estou entre os if's</p>\n\n"
" @if (true)\n"
" <div>estou em outro if</div>\n"
" @endif\n"
"</div>")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.