const regex = /^https\:\/\/\w+(-my|-admin){0,1}\.sharepoint\.com((\/\w+[_\-\.']{0,}\w+){0,}[^\.](\w+[-_'\d]{0,})){0,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https\\:\\\/\\\/\\w+(-my|-admin){0,1}\\.sharepoint\\.com((\\\/\\w+[_\\-\\.\']{0,}\\w+){0,}[^\\.](\\w+[-_\'\\d]{0,})){0,}$', 'gm')
const str = `https://sharepoint-admin.sharepoint.com/test82323''sdasd'
https://test.sharepoint.com
https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_
https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}