$re = '/(?<=type-)[A-Za-z]/m';
$str = 'type-a
type-b
type-c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);