package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(?:tom|fred|jim)\/?.*$`)
var str = `/bob/fred/tom/jack
/bob/tom/jack
/bob/tom/
/bob/tom
/bob/jack
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}