$re = '/\/(?:tom|fred|jim)\/?.*$/m';
$str = '/bob/fred/tom/jack
/bob/tom/jack
/bob/tom/
/bob/tom
/bob/jack
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);