#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[[\d:]+\s(WRN|INF|ERR)\]"
Local $sString = "[12:00:49 INF] hello" & @CRLF & _
"[12:00:49 WRN] world" & @CRLF & _
"[12:00:49 ERR] 123" & @CRLF & _
"[12:00:49 INF] 123" & @CRLF & _
"[12:00:49 WRN] world" & @CRLF & _
"[12:00:49 ERR] hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")