re = /^\[[\d:]+\s(WRN|INF|ERR)\]/m
str = '[12:00:49 INF] hello
[12:00:49 WRN] world
[12:00:49 ERR] 123
[12:00:49 INF] 123
[12:00:49 WRN] world
[12:00:49 ERR] hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end