$re = '/(.*)-.{5}/m';
$str = 'weave-net-kxpxc
weave-net-jjkki
weave-net-asdkk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);