Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r'''
(?x) https?:// (?: (?:www|m)\. (?:tiktok.com)\/ (?:v|embed|trending) (?:\/)? (?:\?shareId=)? ) (?P<id>[\da-z]+)
'''
gm
Input 1
1
New
https://m.tiktok.com/h5/share/usr/6641141594707361797.html https://m.tiktok.com/v/6749869095467945218.html https://www.tiktok.com/@cchelseameow/video/6751181801206729990 https://www.tiktok.com/embed/6567659045795758085 https://www.tiktok.com/share/user/6567659045795758085 https://www.tiktok.com/trending?shareId=6744531482393545985