package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((25[0-5]|2[0-4]\d|1\d{2}|\d{1,2})\.){3}(25[0-5]|2[0-4]\d|1\d{2}|\d{1,2})$`)
var str = `144.109.279.255
204.131.100.104`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}