re = /^((25[0-5]|2[0-4]\d|1\d{2}|\d{1,2})\.){3}(25[0-5]|2[0-4]\d|1\d{2}|\d{1,2})$/m
str = '144.109.279.255
204.131.100.104'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end