#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(\-\..*)"
Local $sString = "filename.jpeg" & @CRLF & _
"filename-.png" & @CRLF & _
"file name.doc" & @CRLF & _
"file name 3.mp4" & @CRLF & _
"file name -.dxg" & @CRLF & _
"file.name.mov"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)