const regex = /\w+[\,]\w+|\.|\w+|\?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+[\\,]\\w+|\\.|\\w+|\\?', 'g')
const str = `mary went to garden. where is mary? mary is carrying apple and milk. what mary is carrying? apple,milk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}