$re = '/(?![0-6][0-4][0])[0-9]{3}/m';
$str = 'So it would match 664 and 641, but not 440 and 640.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);