$re = '/color/';
$str = 'If you write color multiple times in a text, the g flag will find all occurrences of the word color, instead of the first match only.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);