import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*\\bRing\\b.*)(?=.*\\bbinden\\b.*).*\\bDunkel\\b.*";
final String string = "Ein Ring, sie zu knechten, sie alle zu finden ins Helle zu treiben und ewig zu binden";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}