re = /(?=.*\bRing\b.*)(?=.*\bbinden\b.*).*\bDunkel\b.*/
str = 'Ein Ring, sie zu knechten, sie alle zu finden ins Helle zu treiben und ewig zu binden'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end