using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((MR|VR) ){1}((LAS|VIE|FAD) \d{1,3}.\d{1,3}.\d{1,3}( )){1}(\d{1,3}(P)){1}( DUMMY)?";
string input = @"MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P Postfix
Prefix MR LAS 1.01.01 4P Kürbis Postfix
MR LAS 1.01.01 fail 4P Postfix
MR LAS 1.01.01 fail 4P Kürbis Postfix
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}