// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((MR|VR) ){1}((LAS|VIE|FAD) \d{1,3}.\d{1,3}.\d{1,3}( )){1}(\d{1,3}(P)){1}( DUMMY)?").unwrap();
let string = "MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P Postfix
Prefix MR LAS 1.01.01 4P Kürbis Postfix
MR LAS 1.01.01 fail 4P Postfix
MR LAS 1.01.01 fail 4P Kürbis Postfix
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}