#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[a-z])(?=[A-Z])"
Local $sString = "MayTheRangeForceBeWithYou" & @CRLF & _
"HaroldAndKumarEscapeFromGuantanamoBay" & @CRLF & _
"HaroldAndKumarGoToWhiteCastle"
Local $sSubst = "\x20"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)