package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-D][0-9:\$\.\+\-\/]+[A-D]`)
var str = `A123456A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}