#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)extend\s+([^n]*)(?:(?P<phase>colloid|mineral|basis|isotope|solid-solution)\s+)?(?P<species>[^\n ]+)\s+({(?P<content>((?:[^{}]++|(?4))*))})"
Local $sString = "extend mineral Uraninite {" & @CRLF & _
" kinetics {" & @CRLF & _
" rate = -3.2e-08 mol/m2/s" & @CRLF & _
" area = Uraninite" & @CRLF & _
" y-term, species = Uraninite" & @CRLF & _
" w-term {" & @CRLF & _
" species = H[+]" & @CRLF & _
" power = 0.37" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" kinetics {" & @CRLF & _
" rate = 3.2e-09 mol/m2/s" & @CRLF & _
" area = Uraninite" & @CRLF & _
" y-term, species = Uraninite" & @CRLF & _
" w-term {" & @CRLF & _
" species = H[+]" & @CRLF & _
" power = 0.37" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")