package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)extend\s+([^n]*)(?:(?P<phase>colloid|mineral|basis|isotope|solid-solution)\s+)?(?P<species>[^\n ]+)\s+({(?P<content>((?:[^{}]++|(?4))*))})`)
var str = `extend mineral Uraninite {
kinetics {
rate = -3.2e-08 mol/m2/s
area = Uraninite
y-term, species = Uraninite
w-term {
species = H[+]
power = 0.37
}
}
kinetics {
rate = 3.2e-09 mol/m2/s
area = Uraninite
y-term, species = Uraninite
w-term {
species = H[+]
power = 0.37
}
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}