// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]{1,2}\d{1,2}(?:(?: )?\d[A-Z]{2})?$").unwrap();
let string = "AA9
AA99
AA9 9ZZ
AA99 9ZZ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}