# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Q: (.+(?:\n(?![QA]: ).+)*)(?:\n+(?![QA]: ).+)*\n+A: (.+(?:\n(?![QA]: ).+)*)"
test_str = ("Q: How do you use this style?\n"
"A: Just like this.\n\n"
"Q: Can the question\n"
"run over multiple lines?\n"
"A: Yes, and\n"
"So can the answer\n\n"
"Q: Does the answer need to be immediately after the question?\n\n\n"
"A: No, and preceding whitespace will be ignored.\n\n"
"Q: This is my question\n"
"This is my second line of my question and my question will end when i use this 3 dots, but i dont have to use it, if no additional text is between Q: & A: °°°\n\n"
"This is additional text on a new line, which should not be detected as a part of my question or answer, nor should it destroy the functionality.\n\n"
"A: This is my Answer.\n"
"My second line of the Answer °°° This is additional Text on the same line, which should not be detectet as my Answer. So as you can see, it should be possible to make an additional text on the same line, but also on a new line.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.