# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https?:\/\/\Qeem.mydomain.com\E\/\K\d{4}\/\d{2}\/([^"'>]*?)\.html/energy-environment-blog\/$1/g;t' <<< "Hello there how are <a
href=\"http://eem.mydomain.com/2015/06/court-compels-epa-to-
respond.html\">some link name</a> there how are there how are
<a href=\"http://eem.mydomain.com/2014/03/wv-clean-air-act-case.html\">another
link name</a>"