# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?://\Qeem.mydomain.com\E/\K\d{4}/\d{2}/([^\"'>]*?)\.html"
test_str = ("Hello there how are <a \n"
"href=\"http://eem.mydomain.com/2015/06/court-compels-epa-to-\n"
"respond.html\">some link name</a> there how are there how are \n"
"<a href=\"http://eem.mydomain.com/2014/03/wv-clean-air-act-case.html\">another \n"
"link name</a>")
subst = "energy-environment-blog/$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.