$re = '/^A01H1\d{1,2}(?!\d)/m';
$str = 'A01H100
A01H140
A01H110
A01H100more
A01H140-text
A01H110...here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);