using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/DomainId\/(?P<DomainId>\d{5,9})\b|/DomainainSiteId\/(?P<DomainainSiteId>\d{5,9})\b";
string input = @"https://company.db.abcd.com/DomainId/123456789/Other https://company.db.abcd.com/DomainainSiteId/123456/Other https://companyaddedwords.db.abcd.com/DomainId/1234567/Other";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}