package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<span id=["'](ctl00_.+|other_ids)["']>(.+?)<\/span>`)
var str = `<span id="ctl00_BodyContentPlaceHolder_lblDescription">Random Description</span>
<span id='ctl00_BodyContentPlaceHolder_lblDescription'>Random Description</span>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}