import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span id=[\"'](ctl00_.+|other_ids)[\"']>(.+?)<\\/span>";
final String string = "<span id=\"ctl00_BodyContentPlaceHolder_lblDescription\">Random Description</span>\n"
+ "<span id='ctl00_BodyContentPlaceHolder_lblDescription'>Random Description</span>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}