re = /\d{3}\B\K/m
str = '12345678911
111222333444
11222333444'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result