import re
regex = re.compile(r"typedef enum\s*{([^;*]+)}rba_EcuSecu", flags=re.MULTILINE)
test_str = ("typedef enum\n"
"{\n"
" CONTEXT_0 = 0,\n"
" CONTEXT_1 = 1,\n"
" CONTEXT_2 = 2,\n"
" CONTEXT_3 = 7,\n"
"}aes_context_e;\n\n"
"typedef enum\n"
"{\n"
" CIPHER_MATCH_E = 0,\n"
" CIPHER_NOT_MATCHED_E = 1,\n"
" CIPHER_MATCH_NOT_POSSIBLE_E = 3,\n"
" CIPHER_MATCHED_TAG_NOT_MATCHED = 5,\n"
" CIPHER_NOT_MATCHED_TAG_MATCHED = 6,\n"
"}rba_EcuSecu_AES_CipherChk_e;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")