import re
regex = re.compile(r"(https?:\/\/www\.(?:filepicker\.io\/|filestack\.com\/)api\/file\/[\w+?&=\/]+)", flags=re.MULTILINE)
test_str = ("\n"
"<img src=\"https://www.filepicker.io/api/file/someotherfile\" />\n"
"<a href='https://www.filestack.com/api/file/anothersdf?sdf=3&dfdf=1'>link</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")