// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/www\.(?:filepicker\.io\/|filestack\.com\/)api\/file\/[\w+?&=\/]+)").unwrap();
let string = "
<img src=\"https://www.filepicker.io/api/file/someotherfile\" />
<a href='https://www.filestack.com/api/file/anothersdf?sdf=3&dfdf=1'>link</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}