#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(!?(<.*?>)|[^<]+)\s*"
Local $sString = "<div class="testing" style="color:red" .... more attributes and id="test">text</div>" & @CRLF & _
"<div class="testing" ...some attributes... id="test".... some attributes....>text</div>" & @CRLF & _
"<div id="test" .........any number of attributes>text</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")