package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(!?(<.*?>)|[^<]+)\s*`)
var str = `<div class="testing" style="color:red" .... more attributes and id="test">text</div>
<div class="testing" ...some attributes... id="test".... some attributes....>text</div>
<div id="test" .........any number of attributes>text</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}