package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.+?@.+?\.autos`)
var str = `From: "Costco Rewards" <costco.rewards@callipygianhalcyon.autos>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}