#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+(?=\d{4}$)"
Local $sString = "December 2005" & @CRLF & _
"January 2008" & @CRLF & _
"January 3, 2001" & @CRLF & _
"December 18, 2004"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)