$re = '/^(.+?\.auto)\../m';
$str = 'adsense.auto. 86400 in nsec adwords.auto. NS NSEC RRSIG
adwords.auto. 900 in ns ns1.google.com.
adwords.auto. 900 in ns ns2.google.com.
adwords.auto. 900 in ns ns3.google.com.
adwords.auto. 900 in ns ns4.google.com.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);