#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$\d+(?![0-9.])"
Local $sString = "5x Item C $2.5x5, $2.50x1" & @CRLF & _
"1 Book $2.55" & @CRLF & _
"1x Table $2.59" & @CRLF & _
"2x Item A $2000.5x2, 10x Item B $0.5x10" & @CRLF & _
"1x Test $2.513, 5x Pear $100x5" & @CRLF & _
"$1.430" & @CRLF & _
"$1.50 " & @CRLF & _
"$1.55" & @CRLF & _
"10x Tee $0.5x10" & @CRLF & _
"50x SSS $6.5x50" & @CRLF & _
"$2.5, $50"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")