import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\d+(?![0-9.])";
final String string = "5x Item C $2.5x5, $2.50x1\n"
+ "1 Book $2.55\n"
+ "1x Table $2.59\n"
+ "2x Item A $2000.5x2, 10x Item B $0.5x10\n"
+ "1x Test $2.513, 5x Pear $100x5\n"
+ "$1.430\n"
+ "$1.50 \n"
+ "$1.55\n"
+ "10x Tee $0.5x10\n"
+ "50x SSS $6.5x50\n"
+ "$2.5, $50";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}