const regex = /\$\d+(?![0-9.])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\d+(?![0-9.])', 'gm')
const str = `5x Item C \$2.5x5, \$2.50x1
1 Book \$2.55
1x Table \$2.59
2x Item A \$2000.5x2, 10x Item B \$0.5x10
1x Test \$2.513, 5x Pear \$100x5
\$1.430
\$1.50
\$1.55
10x Tee \$0.5x10
50x SSS \$6.5x50
\$2.5, \$50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}